読者です 読者をやめる 読者になる 読者になる

”The following packages have been kept back”

apt-get update すると下記のようなメッセージを見かける。

以下のパッケージは保留されます:
# The following packages have been kept back:(英語の場合)
linux-headers-server linux-image-server linux-server

How do I upgrade the kernel in Ubuntu Server 10.04? - Server Fault によれば、

apt-get dist-upgrade

ディストリビューションのアップグレードをするらしいのだが、それによって何か不具合が起こるのが怖いという方は、

apt-get install linux-headers-server linux-image-server linux-server

のように保留されているパッケージを指定して、該当のパッケージだけアップデートすればOKらしい。でも、ubuntu - Upgrading linux-headers-server and linux-image-server fails - Server Fault みたいに失敗している人もいるから怖い。なんでhave been kept backしているんでしょうね。