読者です 読者をやめる 読者になる 読者になる

RMagick - ImageMagick間のバージョンを無視したい

RMagickをインストールするときに、ImageMagickとバージョンが合わなかったりするとき有りますよね。

This installation of RMagick was configured with ImageMagick 6.6.7 but ImageMagick 6.6.9-9 is in use.

こんなエラーを見ると大変憂鬱になります。かといって、ImageMagickをアップデートするのも安易にやりたくないし…。

なので、environment.rb に下記のように書き込んでおきましょう。rails3だとapplication.rbかな? こうすれば、RMagickはImageMagickのバージョンを無視してくれるはずです。きっとね…。

RMAGICK_BYPASS_VERSION_TEST = true